The screen goes black when you attempt an HQ or HQ+ render in Visual Impression. You also notice that the floor textures along with doors and windows are missing.
Cause
Visual Impression requires a set of files referred to as the "visual cache" or "VS3D Engine." These files initially get installed with the software under the user profile who installs the software. So if another person uses the program other than who installed it, they will typically be missing the cache files and will experience the above problem. These are the most common reasons you could be missing these files:
- You are a new user to the computer which was previously used by someone else.
- The software was installed for you by your help desk and then provided to you.
- You do not have local admin rights to the computer and had to enter an admin password to install the software.
Solution 1
You will need to install the VS3D Engine files for your user profile. If you have local admin rights, this is the easiest solution. If you do not have admin rights, or are prompted to enter a user name and password in order to install the below file, then you will likely need to use Solution 2.
- Fully exit and close all applications (Worksheet, Giza, Cap / AutoCAD)
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Click here to download the Setup_VS3DEngine.exe file.
- Run the file when it is finished downloading.
- Click Next on the Setup - 20-20 3D Engine screen
- Click Yes on the Folder Exists message.
- Click Next if the following screen appears.
- The files will now install. Click Finish when the setup is complete.
- Reopen Visual Impression and test if this has solved the problem. If you still are experiencing the issue, then refer to Solution 2 below.
Solution 2
If you had trouble with solution 1 downloading the .exe file, or you do not have admin rights to install the file, this solution will have you download a ZIP file that contains the same files, but you will need to manually copy them to the correct location. This solution can be used to get the files installed without needing to have admin rights in most cases.
- Fully exit and close all applications (Worksheet, Giza, Cap / AutoCAD, VI)
- Download this zip file and save it to your computer: vicache.zip
- Open the zip file and you should see a folder inside called Cache.
- Right-click on the Cache folder and choose Copy
- At the top of the Windows File Explorer window, type %localappdata% and press enter.
- Now find and double click into the CAP folder.
- Now find and double click into the Visual Folder.
- Here you will see your existing Cache folder. We need to now Paste the Cache folder we downloaded from the ZIP here, so that we replace your Cache folder with the copy contained in the Zip file. Right click somewhere below this folder in the white space and choose "Paste".
- This may take a few moments to copy. You may also be prompted asking if you wish to replace any files. It is ok to choose to replace the files in the destination. Once it is finished copying, you can reopen Visual Impression and verify if this has solved the issue.
Solution 3
This solution involves manually copying the visual cache folder from the user profile folder who installed the program to the user profile folder of the user experiencing the problem. For example, if the software was installed by the administrator or an administrator account was required to install the above 3D Engine file, then the files end up getting installed to the admin profile. Therefore, the files are still unavailable to the user profile when the application is used.
- Fully exit and close all applications (Worksheet, Giza, Cap / AutoCAD)
- Open Windows Explorer (Holding down the Windows logo key + e is a keyboard shortcut to open Windows Explorer)
- Navigate to C:\Users\<User Profile>\AppData\Local\CAP\Visual - <User Profile> in the path being the profile that initially installed the software or VS3D Engine.
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Copy the Cache folder.
- Navigate to C:\Users\<User Profile>\AppData\Local\CAP\Visual - <User Profile> this time being the profile of the user experiencing the problem.
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Paste the Cache folder you copied from step 4 and have it overwrite or merge with the existing cache folder in this location.
- Reopen Visual Impression and verify this has solved the issue.
Tip: The AppData folder is a hidden folder. It is recommended you set your PC to show hidden files and folders as described here.